ConnexionConnexionInscription
B E A D G
149 connectés Aller à Sweepyto Guitare

Problème de config JACK

#1
10/06/2014 12:27:44
Bonjour la troupe,
Dans l'optique de supprimer Windows de mon ordinateur, je me suis mis à la MAO sous Linux (j'étais sous Cubase avant).
Du coup, Ardour d'impose forcément et avec la config de Qjackctl. Du coup sur la matinée à m'arracher les cheveux sur la config de mon interface audio dessus, je réussis enfin à enregistrer une piste sur Ardour!
Du coup je fais le routage sur Ardour, tout me semble logique mais... Pas de son en sortie du bus master, alors que le vumètre bouge correctement.
Je tiens à préciser que sur Windows tout marche bien et que le son sous Linux marche bien hors-Jack (Pulseaudio entre autres).
Du coup j'ai essayé plein de configs sur Ardour et Jack, mais jamais de son...
J'ai cherché sur Google, j'ai configuré comme les mecs font mais rien du tout!
Du coup, je me suis dit que ça pouvait venir de Jack lui-même. Donc j'ai fermé Ardour, ouvert Audacity avec Jack derrière (pas ALSA) et là, même processus : l'enregistrement se fait, pas de souci, le vu-mètre lors de la lecture marche bien mais pas de son dans mes écouteurs!
Donc je fais une pause clope-thé   et lorsque je relance Qjackctl... Bah... C'est pire.
Je configure correctement mon matos, exactement comme la session d'avant mais Ardour n'enregistre que les sons produits en interne par mon ordi, entre autres... Les clics de ma souris. Hé ouais. Par contre, il me les joue sur les hauts-parleurs, mais pas sur le casque!
J'y comprends plus rien... Quelqu'un comprend quelque chose au Kamoulox?
Merci.
0
0
#2
10/06/2014 12:33:39
Je viens de redémarrer mon ordinateur, et... C'est encore pire.
J'ai touché à rien, j'ai lancé le serveur Jack et j'ai eu un message d'erreur genre :


12:30:56.227 Baie de brassage désactivée.

12:30:56.227 Réinitialisation des statistiques.

12:30:56.240 Changement des connexions ALSA.

12:30:56.246 DBUS : le service est disponible (org.jackaudio.service soit jackdbus).

Cannot connect to server socket err = Aucun fichier ou dossier de ce type

Cannot connect to server request channel

jack server is not running or cannot be started

12:30:56.255 Changement du graphique des connexions ALSA.

12:31:30.967 DBUS : impossible de démarrer le serveur JACK. Désolé

Cannot connect to server socket err = Aucun fichier ou dossier de ce type

Cannot connect to server request channel

jack server is not running or cannot be started

Tue Jun 10 12:31:30 2014: Starting jack server...

Tue Jun 10 12:31:30 2014: JACK server starting in non-realtime mode

Tue Jun 10 12:31:30 2014: ERROR: Cannot lock down 82274202 byte memory area (Cannot allocate memory)

Tue Jun 10 12:31:30 2014: ERROR: cannot register object path "/org/freedesktop/ReserveDevice1/Audio1": A handler is already registered for /org/freedesktop/ReserveDevice1/Audio1

Tue Jun 10 12:31:30 2014: ERROR: Failed to acquire device name : Audio1 error : A handler is already registered for /org/freedesktop/ReserveDevice1/Audio1

Tue Jun 10 12:31:30 2014: ERROR: Audio device hw ro,1 cannot be acquired...

Tue Jun 10 12:31:30 2014: ERROR: Cannot initialize driver

Tue Jun 10 12:31:30 2014: ERROR: JackServer: pen failed with -1

Tue Jun 10 12:31:30 2014: ERROR: Failed to open server

Tue Jun 10 12:31:32 2014: Saving settings to "/home/baptiste/.config/jack/conf.xml" ...

12:31:38.637 Impossible de connecter le serveur JACK comme client. - L'opération a échoué. - Incapable de se connecter au serveur. Veuillez consulter la fenêtre des messages pour plus d'informations.

Cannot connect to server socket err = Aucun fichier ou dossier de ce type

Cannot connect to server request channel

jack server is not running or cannot be started



Je crois que je peux pas tomber plus bas là...
Enfin, il démarre correctement quand je mets les entrées et sorties sur "par défaut" mais Ardour fonctionne pas. Curieux...
0
0
#3
10/06/2014 19:34:24
salut, vois peut-être sur le forum de linuxMAO.org, j'avais tâté un peu de ubuntu studio et c'est vrai que la configuration de Jack quand ça veut pas...  
0
0
#5
10/06/2014 20:06:01
 ah bah en plus c'est résolu !  heureusement qu'il y a des génies du terminal, des fois je sais pas où ils vont chercher toutes ces commandes... 
0
0

En Live

Itchy67000 vient tout juste de rejoindre la communauté Slappyto. Bienvenue ! il y a 2 jours
Petifumiste a commenté le topic [Ibanez BTB 555 MP 380€] de petifumiste il y a 2 jours
Didier ridoux a commenté le topic [Fernandes APB-100] de Axel Faure il y a 3 jours
Didier ridoux vient tout juste de rejoindre la communauté Slappyto. Bienvenue ! il y a 3 jours
Lardon : Nouvel interview il y a 3 jours
Harryknot vient tout juste de rejoindre la communauté Slappyto. Bienvenue ! il y a 3 jours
Dambass vient tout juste de rejoindre la communauté Slappyto. Bienvenue ! il y a 3 jours
ZumZum et djeroon ont commenté le topic [Octaver ou 5ème corde (Si/B)? ] de djeroon il y a 4 jours
Reymo a commenté le topic [Super Alim pour pedalboard ] de ilanonbass il y a 6 jours